Skip to main content
VulnerabilityPublished Updated

CVE-2026-31958: Moderate · python-tornado security update

Affects python3-tornadoSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-31958· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 6.5.5-1.el10_1.1 soon.

Data as of 27 Oct 2026, 01:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.5.5-1.el10_1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux python3-tornado package to 6.5.5-1.el10_1.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10python3-tornadoAffected
  • <6.5.5-1.el10_1.1
Fixed in
  • 6.5.5-1.el10_1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 6.5.5-1.el10_1.1 of python-tornado is available and should be applied to remediate these vulnerabilities. Users should update affected packages as per the Red Hat advisory instructions. No additional mitigation steps are indicated beyond applying the official patch.

Description

A security update for python-tornado addresses a denial of service vulnerability caused by large multipart bodies (CVE-2026-31958) and a cookie attribute injection issue due to improper handling of cookie arguments (CVE-2026-35536). The vulnerabilities affect versions prior to 6.5.5-1.el10_1.1. The update is rated as having a moderate security impact.

References

Community reviews

Loading reviews…