Skip to main content
VulnerabilityPublished Updated

CVE-2026-30922: Molecule · Denial of Service in pyasn1 via Unbounded Recursion

Affects moleculeSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 26.3.0_1 or 3.0.5 soon.

Data as of 1 Nov 2026, 01:50 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 26.3.0_1, 3.0.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade molecule to 26.3.0_1 or 3.0.5.

Affected software

ProductAffectedFixed in
Homebrewmoleculepkg:brew/moleculeOther threatsAffected
  • >=1.17.3 <3.0.5
  • >=25.7.0 <26.3.0_1
Fixed in
  • 3.0.5
  • 26.3.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading pyasn1 to versions 3.0.5 or 26.3.0_1 or later. The vendor advisory confirms the availability of this fix. No additional mitigation steps are required once the update is applied. Users should ensure that all affected systems are updated promptly to prevent exploitation.

Description

The pyasn1 library suffers from a Denial of Service vulnerability due to unbounded recursion when decoding ASN.1 data with deeply nested indefinite-length SEQUENCE or SET structures. An attacker can craft a payload that triggers recursive decoding calls without depth limits, causing the Python interpreter to crash with a RecursionError or exhaust memory, leading to service crashes or resource exhaustion. This affects services using pyasn1 for ASN.1 parsing such as LDAP, SNMP, Kerberos, and X.509 parsers. The vulnerability is fixed in pyasn1 versions 3.0.5 and 26.3.0_1.

References

Community reviews

Loading reviews…