Skip to main content
VulnerabilityPublished Updated

CVE-2025-0755: MongoDB C Driver bson library may be susceptible to buffer overflow

Affects mongodbSource GCVE Database

0

Not known to be exploited : upgrade to 8.0.1 or 7.0.16 soon.

Data as of 26 Oct 2026, 12:54 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.1, 7.0.16

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mongodb to 8.0.1 or 7.0.16.

Affected software

ProductAffectedFixed in
Bitnamimongodbpkg:bitnami/mongodbOther threatsAffected
  • >=7.0.0 <7.0.16
  • >=8.0.0 <8.0.1
Fixed in
  • 7.0.16
  • 8.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to libbson version 1.27.5 or later, MongoDB Server v7.0.16 or later, and MongoDB Server v8.0.1 or later. These versions contain fixes that prevent buffer overflow conditions in the bson_append functions. No additional mitigation steps are indicated.

Description

A buffer overflow vulnerability exists in the MongoDB C driver bson library's bson_append functions when constructing BSON documents that exceed the maximum size limit (INT32_MAX). This can cause segmentation faults and application crashes. The issue affects libbson versions prior to 1.27.5, MongoDB Server v7.0 versions before 7.0.16, and MongoDB Server v8.0 versions before 8.0.1. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…