CVE-2024-34005: moodle · authenticated LFI risk in some misconfigured shared hosting environments via modified mod_data backup
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.3.4 : update moodle when convenient.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3.4, 4.2.7, 4.1.10
Exploitation evidence
Disclosed: evidence found.
CVE published 2 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade moodle to 4.3.4, 4.2.7 or 4.1.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Moodle to versions 4.1.10 or later, 4.2.7 or later, or 4.3.4 or later as appropriate. Ensuring proper isolation and configuration in shared hosting environments to prevent unauthorized access to other users' content is also recommended.
Description
CVE-2024-34005 is a medium severity vulnerability affecting Moodle in certain misconfigured shared hosting environments. It allows an authenticated Moodle user with permissions to restore database activity modules and direct web server access outside the Moodle webroot to perform a local file inclusion (LFI) attack. This issue arises only if the hosting environment improperly permits access to other users' content. A patch is available to address this vulnerability.