Skip to main content
VulnerabilityPublished Updated

CVE-2026-25506: MUNGE is an authentication service for creating and validating user credentials

Affects mungeSource GCVE Database

0
Authoritative record:CVE-2026-25506· High 7.7

Not known to be exploited · CVSS 7.7 High · fixed in 0.5.11-1ubuntu1.1+esm1 : patch munge soon.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.5.11-1ubuntu1.1+esm1, 0.5.11-3ubuntu0.1+esm1, 0.5.13-1ubuntu0.1~esm1 +4
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10mungepkg:deb/ubuntu/munge?arch=source&distro=questingOther threatsAffected
  • <0.5.16-1ubuntu0.1
Fixed in
  • 0.5.16-1ubuntu0.1
Ubuntu 24.04 LTSmungepkg:deb/ubuntu/munge?arch=source&distro=nobleOther threatsAffected
  • <0.5.15-4ubuntu0.1
Fixed in
  • 0.5.15-4ubuntu0.1
Ubuntu 22.04 LTSmungepkg:deb/ubuntu/munge?arch=source&distro=jammyOther threatsAffected
  • <0.5.14-6ubuntu0.1
Fixed in
  • 0.5.14-6ubuntu0.1
Ubuntu Pro 20.04 LTSmungepkg:deb/ubuntu/munge?arch=source&distro=esm-apps/focalOther threatsAffected
  • <0.5.13-2ubuntu0.1~esm1
Fixed in
  • 0.5.13-2ubuntu0.1~esm1
Ubuntu Pro 18.04 LTSmungepkg:deb/ubuntu/munge?arch=source&distro=esm-apps/bionicOther threatsAffected
  • <0.5.13-1ubuntu0.1~esm1
Fixed in
  • 0.5.13-1ubuntu0.1~esm1
Ubuntu Pro 16.04 LTSmungepkg:deb/ubuntu/munge?arch=source&distro=esm-apps/xenialOther threatsAffected
  • <0.5.11-3ubuntu0.1+esm1
Fixed in
  • 0.5.11-3ubuntu0.1+esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

MUNGE is an authentication service for creating and validating user credentials. From 0.5 to 0.5.17, local attacker can exploit a buffer overflow vulnerability in munged (the MUNGE authentication daemon) to leak cryptographic key material from process memory. With the leaked key material, the attacker could forge arbitrary MUNGE credentials to impersonate any user (including root) to services that rely on MUNGE for authentication. The vulnerability allows a buffer overflow by sending a crafted message with an oversized address length field, corrupting munged's internal state and enabling extraction of the MAC subkey used for credential verification. This vulnerability is fixed in 0.5.18.

References

Community reviews

Loading reviews…