Skip to main content
CVE-2026-25506VulnerabilityPublished Updated

CVE-2026-25506: dun munge · Out-of-bounds Write

Affects dun mungeSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 0.5.18 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.5.18
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade dun munge to 0.5.18.

Affected software

ProductAffectedFixed in
dunmungeAffected
  • >=0.5 <0.5.18
Fixed in
  • 0.5.18

AI-suggested

An official fix is available in MUNGE version 0.5.18. Users and administrators should upgrade affected MUNGE installations to version 0.5.18 or later to remediate this vulnerability. Red Hat has released security advisories and errata with updated packages for affected Red Hat Enterprise Linux versions. Applying these vendor-provided updates will mitigate the issue. Patch status is confirmed by vendor advisories. No additional mitigations are specified beyond applying the official update.

Description

MUNGE is an authentication service for creating and validating user credentials. From 0.5 to 0.5.17, local attacker can exploit a buffer overflow vulnerability in munged (the MUNGE authentication daemon) to leak cryptographic key material from process memory. With the leaked key material, the attacker could forge arbitrary MUNGE credentials to impersonate any user (including root) to services that rely on MUNGE for authentication. The vulnerability allows a buffer overflow by sending a crafted message with an oversized address length field, corrupting munged's internal state and enabling extraction of the MAC subkey used for credential verification. This vulnerability is fixed in 0.5.18.

References

Community reviews

Loading reviews…