n8n before 1.123.85, 2.43.5, and 2.44.1 contains a regular expression denial of service vulnerability that allows
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 1.123.85 soon.
Data as of 28 Oct 2026, 22:27 UTC
- Patch
- Available – fixed in 1.123.85, 2.44.1, 2.43.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n versions 1.123.85, 2.43.5, and 2.44.1. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigation or workaround is indicated.
Description
A regular expression denial of service (ReDoS) vulnerability exists in n8n versions before 1.123.85, 2.43.5, and 2.44.1. Authenticated users who can create and run workflows may exploit this by submitting specially crafted wildcard-heavy File(s) Selector patterns. This causes exponential backtracking in the regex engine, blocking the event loop and rendering the UI, API, webhooks, and health checks unresponsive until the service is restarted.