CVE-2026-118646: n8n · ReDoS
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 1.123.85 soon.
Data as of 28 Oct 2026, 19:27 UTC
- Patch
- Available – fixed in 1.123.85, 2.44.1, 2.43.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n to version 1.123.85, 2.43.5, or 2.44.1 or later where the vulnerability is fixed. No other mitigation or workaround is indicated. Applying the official patches fully addresses the issue.
Description
n8n versions prior to 1.123.85, 2.43.5, and 2.44.1 contain a regular expression denial of service (ReDoS) vulnerability. Authenticated users who can create and run workflows may exploit this by submitting crafted glob patterns with excessive wildcards, causing exponential backtracking. This results in blocking the event loop and making the UI, API, webhooks, and health checks unresponsive until the system is restarted.