CVE-2026-118677: n8n · Improper Authorization in Handler for Custom URL Scheme
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.42.1 when convenient.
Data as of 28 Oct 2026, 19:27 UTC
- Patch
- Available – fixed in 2.42.1, 2.41.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n to 2.42.1; n8n to 2.41.4; n8n to 2.42.1 or 2.41.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n Local Gateway desktop app to version 2.41.4 or later, or 2.42.1 or later, where this vulnerability is fixed. No other mitigation is indicated or required as the fix is available in these versions.
Description
CVE-2026-118677 is a vulnerability in n8n's Local Gateway desktop app before versions 2.41.4 and 2.42.1. It involves improper authorization in the deep-link connect handler for the custom URL scheme n8n-computer-use://. This flaw allows an attacker to silently re-pair the app with a malicious n8n instance by tricking a user into opening a crafted link, inheriting previously granted permissions and potentially acting on the user's computer through the gateway.