CVE-2026-118679: n8n · Server-Side Request Forgery (SSRF)
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.123.83 when convenient.
Data as of 28 Oct 2026, 19:27 UTC
- Patch
- Available – fixed in 1.123.83, 2.42.1, 2.41.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n to one of the fixed versions: 1.123.83, 2.41.4, or 2.42.1. These versions contain the official fix for this SSRF vulnerability. Until upgraded, ensure that a signing secret is configured for Slack Trigger webhooks to prevent bypass of signature verification. No other mitigations are specified.
Description
CVE-2026-118679 is a server-side request forgery (SSRF) vulnerability in the Slack Trigger webhook of n8n versions before 1.123.83, 2.41.4, and 2.42.1. This flaw allows unauthenticated attackers to bypass signature verification when no signing secret is set, enabling them to exfiltrate Slack workspace access tokens by triggering the webhook with a specially crafted request. The vulnerability is fixed in versions 1.123.83, 2.41.4, and 2.42.1.