Skip to main content
VulnerabilityPublished

CVE-2026-118675: n8n · Incorrect Authorization

Affects n8nSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.123.85 when convenient.

Data as of 28 Oct 2026, 19:27 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.123.85, 2.44.1, 2.43.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:H/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • <1.123.85
Fixed in
  • 1.123.85
n8n-ion8nAffected
  • >=2.44.0 <2.44.1
Fixed in
  • 2.44.1
n8n-ion8nAffected
  • >=2.0.0 <2.43.5
Fixed in
  • 2.43.5
npmn8npkg:npm/n8nOther threatsAffected
  • <1.123.85
  • >=2.44.0 <2.44.1
  • >=2.0.0 <2.43.5
Fixed in
  • 1.123.85
  • 2.44.1
  • 2.43.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions 1.123.85, 2.43.5, and 2.44.1 address this vulnerability. Users should upgrade to these or later versions to remediate the issue. No other mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-118675 is a credential guard bypass vulnerability in n8n versions before 1.123.85, 2.43.5, and 2.44.1. It allows editors of shared workflows to access restricted credentials by exploiting the Execute Sub-workflow node with maliciously crafted source URLs or local files. This vulnerability enables attackers to retrieve decrypted credential values improperly.

References

Community reviews

Loading reviews…