n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 saves the SeaTable Trigger node's API token in error
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 2.44.1 : update n8n when convenient.
Data as of 28 Oct 2026, 22:26 UTC
- Affects
- n8n before 1.123.85
- Patch
- Available – fixed in 2.44.1, 2.43.5, 1.123.85
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n-io/n8n to 2.44.1, 2.43.5 or 1.123.85.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n versions 1.123.85, 2.43.5, and 2.44.1 and later. Users should upgrade to these versions or later to prevent API token exposure. No information about alternative mitigations or temporary workarounds is provided.
Description
A vulnerability in n8n versions before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 causes the SeaTable Trigger node's API token to be saved in error execution data. This occurs because failed poll requests store raw request headers, exposing the API token to users who can view workflow executions but do not have credential read access.