Skip to main content
CVE-2026-118677VulnerabilityPublished

n8n before 2.41.4 and 2.42.x before 2.42.1 contains a missing confirmation vulnerability in the Local Gateway desktop

Affects n8nSource GCVE Database

0
Authoritative record:CVE-2026-118677· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.42.1 or 2.41.4 when convenient.

Data as of 28 Oct 2026, 22:14 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.42.1, 2.41.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade n8n to 2.42.1 or 2.41.4.

Affected software

ProductAffectedFixed in
npmn8npkg:npm/n8nOther threatsAffected
  • <2.41.4
  • >=2.42.0 <2.42.1
Fixed in
  • 2.41.4
  • 2.42.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade n8n Local Gateway desktop app to version 2.41.4 or later, or 2.42.1 or later for the 2.42.x series, where this vulnerability is fixed. No other mitigation or workaround is indicated. Patch status is not explicitly confirmed in the input data, but the presence of fixed versions implies that updating to these versions remediates the issue.

Description

A vulnerability in n8n Local Gateway desktop app versions before 2.41.4 and 2.42.x before 2.42.1 allows an attacker to silently re-pair the app with a malicious n8n instance via a crafted deep-link. This can cause the app to connect to an attacker-controlled instance without user confirmation, inheriting previously granted permissions and enabling unauthorized actions through the gateway.

References

Community reviews

Loading reviews…