Skip to main content
VulnerabilityPublished Updated

N8n: Duplicate Advisory: MySQL v1 Node executeQuery Operation Allows SQL Injection via Unparameterized Expression Interpolation

Affects n8nSource GCVE Database

0

CVSS 8.8 High · fixed in 1.123.61 : patch n8n soon.

Data as of 22 Jul 2026, 23:26 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.123.61
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do

Affected software

ProductAffectedFixed in
npmn8nAffected–Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in n8n versions 1.123.61, 2.27.4, and 2.28.1 and later. Users should upgrade to these or newer versions to remediate the vulnerability. Additionally, workflows should migrate from the legacy MySQL v1 node to the MySQL v2 node, which uses parameterized queries and is not affected by this issue.

Description

n8n versions before 1.123.61, 2.x before 2.27.4, and 2.28.x before 2.28.1 contain a SQL injection vulnerability in the legacy MySQL v1 node's executeQuery operation. This vulnerability arises because the operation directly substitutes evaluated expressions into SQL queries without parameterization. If an externally reachable trigger such as a Webhook node passes attacker-controlled input to these expressions, it can lead to arbitrary SQL execution with the privileges of the configured MySQL credentials. The newer MySQL v2 node, which uses parameterized queries, is not affected.

References

Community reviews

Loading reviews…