Skip to main content
CVE-2026-56357VulnerabilityPublished Updated

CVE-2026-56357: n8n · Webhook Forgery on Github Webhook Trigger

Affects n8nSource GCVE Database

0

Not known to be exploited : upgrade to 1.123.15 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.123.15, 2.5.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade n8n to 1.123.15; n8n to 2.5.0.

Affected software

ProductAffectedFixed in
npmn8nAffected
  • <1.123.15
Fixed in
  • 1.123.15
npmn8nAffected
  • >=2.0.0 <2.5.0
Fixed in
  • 2.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in n8n versions 1.123.15 and 2.5.0 and later; users should upgrade to these versions or newer to remediate the vulnerability. If immediate upgrade is not possible, administrators should limit workflow creation and editing permissions to trusted users and restrict network access to the webhook endpoint to known GitHub webhook IP ranges. These workarounds are temporary and do not fully mitigate the risk.

Description

n8n versions prior to 1.123.15 and versions from 2.0.0 up to but not including 2.5.0 contain a vulnerability in the GitHub Webhook Trigger node. This flaw allows an attacker who knows the webhook URL to send unsigned POST requests, triggering workflows with arbitrary data because the node lacks HMAC-SHA256 signature verification. The vulnerability has been fixed in versions 1.123.15 and 2.5.0 and later. Temporary mitigations include restricting workflow editing permissions and limiting network access to known GitHub IP ranges, but these do not fully eliminate the risk.

References

Community reviews

Loading reviews…