Nats server: Prior to 2.14.0, 2.12.7, and 2.11.16, an authenticated user could receive messages on denied subjects
Affects nats-serverSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 2.14.0 : update nats-server when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 26.04 LTSnats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10nats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade NATS Server to version 2.14.0, 2.12.7, or 2.11.16 or later to apply the official fix for this authorization bypass vulnerability.
Description
NATS Server versions prior to 2.14.0, 2.12.7, and 2.11.16 have an authorization bypass vulnerability related to overlapping wildcard subscriptions. Authenticated users may receive messages on subjects that should be denied, and queue subscriptions may improperly affect message delivery. This issue has been fixed in versions 2.14.0, 2.12.7, and 2.11.16.
References
- ubuntu.com/security/CVE-2026-58252 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-58252 (opens in a new tab)
- github.com/nats-io/nats-server/security/advisories/GHSA-wh7g-5m82-pmhr (opens in a new tab)
- github.com/nats-io/nats-server/commit/8ced85a11497f86704a95d960281480ce037386b (opens in a new tab)
- github.com/nats-io/nats-server/commit/a42a6d1e258eb5c3a2190384d31965a4b715e854 (opens in a new tab)
- github.com/nats-io/nats-server/commit/e611ca9604697b02d8f22beb76037400a9cf72e6 (opens in a new tab)
- github.com/nats-io/nats-server/releases/tag/v2.11.16 (opens in a new tab)
- github.com/nats-io/nats-server/releases/tag/v2.12.7 (opens in a new tab)
- github.com/nats-io/nats-server/releases/tag/v2.14.0 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-58252 (opens in a new tab)