Skip to main content
CVE-2026-58253VulnerabilityPublished

Nats server: Prior to 2.14.0, 2.12.7, and 2.11.16, when no_auth_user was configured, a parser fast path intended for

Affects nats-serverSource GCVE Database

0
Authoritative record:CVE-2026-58253· High 8.8

Not known to be exploited · CVSS 8.8 High · fixed in 2.14.0 : patch nats-server soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Affects
NATS Server prior to 2.14.0
Patch
Available – fixed in 2.14.0
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu Pro 26.04 LTSnats-serverpkg:deb/ubuntu/nats-server@2.10.27-1ubuntu0.26.04.1~esm1?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • =2.10.27-1
  • =2.10.27-1build1
  • =2.10.27-1ubuntu0.26.04.1~esm1
Fixed in–
Ubuntu 25.10nats-serverpkg:deb/ubuntu/nats-server@2.10.27-1?arch=source&distro=questingOther threatsAffected
  • =2.10.24-1
  • =2.10.27-1
Fixed in–
Ubuntu 24.04 LTSnats-serverpkg:deb/ubuntu/nats-server@2.10.7-1ubuntu0.3?arch=source&distro=nobleOther threatsAffected
  • 2.9.19-1build1 – 2.10.7-1ubuntu0.3
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade NATS Server to version 2.14.0, 2.12.7, or 2.11.16 or later, where this vulnerability is fixed. No other mitigations are specified.

Description

CVE-2026-58253 is an authentication bypass vulnerability in NATS Server versions prior to 2.14.0, 2.12.7, and 2.11.16. It affects route and leafnode listeners when the no_auth_user configuration is enabled, allowing an unauthenticated peer to bypass inter-server CONNECT authentication and gain associated privileges. The issue is fixed in versions 2.14.0, 2.12.7, and 2.11.16.

References

Community reviews

Loading reviews…