Skip to main content
CVE-2026-58207VulnerabilityPublished Updated

Nats server: Prior to 2.14.3 and 2.12.12, a client able to send account-scoped connection monitoring requests could

Affects nats-serverSource GCVE Database

0
Authoritative record:CVE-2026-58207· High 7.7

Not known to be exploited · CVSS 7.7 High · fixed in 2.14.3 : patch nats-server soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10nats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=stonkingOther threatsAffected
  • =2.10.27-1build1
  • =2.14.1-1
  • =2.14.3-1
Fixed in–
Ubuntu Pro 26.04 LTSnats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • =2.10.27-1
  • =2.10.27-1build1
  • =2.10.27-1ubuntu0.26.04.1~esm1
Fixed in–
Ubuntu 25.10nats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=questingOther threatsAffected
  • =2.10.24-1
  • =2.10.27-1
Fixed in–
Ubuntu 24.04 LTSnats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=nobleOther threatsAffected
  • 2.9.19-1build1 – 2.10.7-1ubuntu0.3
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected NATS Server installations to version 2.14.3 or 2.12.12 or later, where the vulnerability is fixed. No other mitigations are indicated or required.

Description

NATS Server versions prior to 2.14.3 and 2.12.12 contain a vulnerability where specially crafted account-scoped connection monitoring requests can trigger an arithmetic overflow, causing the server to crash. This affects specific Ubuntu package versions of nats-server. The issue is fixed in versions 2.14.3 and 2.12.12. No known exploits are reported in the wild. The vulnerability is rated medium severity with a CVSS score of 7.7.

References

Community reviews

Loading reviews…