CVE-2026-12074: Gptline · Natural Language Toolkit (NLTK) has path traversal in FramenetCorpusReader.frame() that allows arbitrary XML file read, bypassing the nltk.pathsec sandbox (ENFORCE=True)
Affects gptlineSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.0.8_22 soon.
Data as of 18 Sep 2026, 02:18 UTC
- Patch
- Available – fixed in 3.10.0, 1.0.8_22
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gptline to 1.0.8_22; nltk to 3.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPInltk | Affected
| Fixed in
|
Homebrewgptlinepkg:brew/gptlineOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade to a fixed version of NLTK FramenetCorpusReader as indicated by the vendor. The vulnerability is mitigated by rejecting unsafe path components before file access. No additional action is required if the patch is applied.
Description
The NLTK FramenetCorpusReader.frame() method contains a path traversal vulnerability that allows an attacker to read arbitrary XML files outside the intended corpus root directory. This occurs because the method constructs file paths from user-supplied frame names without proper containment checks and bypasses the nltk.pathsec sandbox enforcement. The vulnerability affects versions prior to 3.10.0 and certain 1.0.8 versions. A proof-of-concept demonstrates that an attacker can read sensitive XML files outside the corpus root despite strict sandbox enforcement. The vulnerability has a CVSS score of 7.5 (high severity) and a patch is available.