Skip to main content
VulnerabilityPublished Updated

CVE-2026-42215: Nbdime · GitPython has Command Injection via Git options bypass

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-42215· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 4.0.4_2 soon.

Data as of 26 Oct 2026, 17:27 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_2.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=3.1.1_1 <4.0.4_2
Fixed in
  • 4.0.4_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 4.0.4_2 that fixes this unsafe option bypass. Users should upgrade to this fixed version or later. No other mitigations are indicated by the vendor advisory. The vulnerability is not mitigated by default settings, so upgrading is necessary.

Description

GitPython versions from 3.1.1_1 up to but not including 4.0.4_2 contain a command injection vulnerability via unsafe handling of certain Git options passed as Python keyword arguments. The vulnerability arises because the safety check blocks dangerous Git options only when passed with hyphenated names, but not when passed using underscore-form kwargs, which are later converted to the dangerous flags. This allows attacker-controlled input to execute arbitrary commands during Git operations such as clone, fetch, pull, and push. A fix is available in version 4.0.4_2.

References

Community reviews

Loading reviews…