CVE-2025-54469: github.com/neuvector/neuvector · NeuVector Enforcer is vulnerable to Command Injection and Buffer overflow
Affects github.com/neuvector/neuvectorSource GCVE Database
Not known to be exploited · CVSS 9.9 Critical : upgrade to 5.3.5 as a priority.
Data as of 29 Oct 2026, 23:10 UTC
- Patch
- Available – fixed in 5.3.5, 5.4.7, 0.0.0-20251020133207-084a437033b4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade github.com/neuvector/neuvector to 5.3.5; github.com/neuvector/neuvector to 5.4.7; github.com/neuvector/neuvector to 0.0.0-20251020133207-084a437033b4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/neuvector/neuvector | Affected
| Fixed in
|
| Gogithub.com/neuvector/neuvector | Affected
| Fixed in
|
| Gogithub.com/neuvector/neuvector | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in NeuVector versions 5.3.5, 5.4.7, and later. Users should upgrade to these versions immediately. There is no workaround for this vulnerability. The vendor advises upgrading as soon as possible to prevent exploitation.
Description
NeuVector Enforcer contains a critical vulnerability where environment variables CLUSTER_RPC_PORT and CLUSTER_LAN_PORT are used unsafely to construct shell commands executed via popen without sanitization. This allows command injection and buffer overflow within the enforcer container. The issue is fixed in versions 5.3.5, 5.4.7, and later. No workaround exists; users must upgrade promptly.