Skip to main content
VulnerabilityPublished Updated

CVE-2026-49975: Nginx · Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http

Affects nginxSource GCVE Database

0
Authoritative record:CVE-2026-49975· High 7.5

Not known to be exploited · 32% EPSS · CVSS 7.5 High · fixed in 1.4.6-1ubuntu3.9+esm8 : patch nginx soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
32.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.6-1ubuntu3.9+esm8, 2.4.18-2ubuntu3.17+esm19, 1.10.3-0ubuntu0.16.04.5+esm9 +12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=resoluteOther threatsAffected
  • <2.4.66-2ubuntu2.2
Fixed in
  • 2.4.66-2ubuntu2.2
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.5
Fixed in
  • 1.28.3-2ubuntu1.5
Ubuntu 25.10apache2pkg:deb/ubuntu/apache2?arch=source&distro=questingOther threatsAffected
  • <2.4.64-1ubuntu3.5
Fixed in
  • 2.4.64-1ubuntu3.5
Ubuntu 25.10nginxpkg:deb/ubuntu/nginx?arch=source&distro=questingOther threatsAffected
  • <1.28.0-6ubuntu1.7
Fixed in
  • 1.28.0-6ubuntu1.7
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=nobleOther threatsAffected
  • <2.4.58-1ubuntu8.13
Fixed in
  • 2.4.58-1ubuntu8.13
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.12
Fixed in
  • 1.24.0-2ubuntu7.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Memory Allocation with Excessive Size Value vulnerability in Apache HTTP Server's mod_http leads to denial of service via malicious HTTP requests. This issue affects Apache HTTP Server: from 2.4.17 through 2.4.67.

References

Community reviews

Loading reviews…