Skip to main content
VulnerabilityPublished Updated

CVE-2024-23828: Nginx-UI vulnerable to authenticated RCE through injecting into the application config via CRLF

Affects github.com/0xJacky/Nginx-UISource GCVE Database

0

Not known to be exploited · CVSS 8.8 High : upgrade to 1.9.10-0.20240126104956-d70e37c8575e soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.10-0.20240126104956-d70e37c8575e
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20240126104956-d70e37c8575e.

Affected software

ProductAffectedFixed in
Gogithub.com/0xJacky/Nginx-UIAffected
  • <1.9.10-0.20240126104956-d70e37c8575e
Fixed in
  • 1.9.10-0.20240126104956-d70e37c8575e

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to trusted authenticated users only and monitor for unusual configuration changes.

Description

### Summary Fix bypass to the following bugs - https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-pxmr-q2x3-9x9m - https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-8r25-68wm-jw35 Allowing to inject directly in the `app.ini` via CRLF to change the value of `test_config_cmd` and `start_cmd` resulting in an Authenticated RCE ### Impact Authenticated Remote execution on the host

References

Community reviews

Loading reviews…