Skip to main content
VulnerabilityPublished

ngx-extended-pdf-viewer bundles a version of pdf.js vulnerable to CVE-2026-16633

Affects ngx-extended-pdf-viewerSource GCVE Database

0

Mentioned vulnerabilities

CVSS 8.6 High : upgrade to 29.0.0-rc.3 soon.

Data as of 7 Aug 2026, 06:26 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 29.0.0-rc.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

What to do

Upgrade ngx-extended-pdf-viewer to 29.0.0-rc.3.

Affected software

ProductAffectedFixed in
npmngx-extended-pdf-viewerAffected
  • >=27.0.0-rc.0 <29.0.0-rc.3
Fixed in
  • 29.0.0-rc.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available starting with ngx-extended-pdf-viewer version 29.0.0-rc.3, which includes the upstream fix from pdf.js 6.2.108. Users should upgrade to this version or later to remediate the vulnerability. If upgrading is not immediately possible, mitigate risk by setting pdfDefaultOptions.enableXfa to false if XFA forms are not required, and/or enforce a Content Security Policy that disallows inline scripts. The package provides SBOM and VEX files from version 29.0.0 to verify the applied fix.

Description

ngx-extended-pdf-viewer includes a forked version of Mozilla's pdf.js that is vulnerable to CVE-2026-16633. This vulnerability allows execution of attacker-controlled JavaScript when opening a malicious PDF, potentially impacting the hosting page. The default configuration reduces exposure compared to upstream pdf.js, but enabling XFA forms (enabled by default) still presents risk. A patch is available from version 29.0.0-rc.3, which backports the upstream fix. Workarounds include disabling XFA forms or applying a Content Security Policy to block inline scripts.

References

Community reviews

Loading reviews…