Skip to main content
VulnerabilityPublished Updated

CVE-2026-81726: NLTK · Model-artifact APIs bypass pathsec and touch files outside allowed roots

Affects safetySource GCVE Database

0

Not known to be exploited · CVSS 7.0 High : upgrade to 3.8.1_3 soon.

Data as of 27 Oct 2026, 06:43 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.8.1_3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade safety to 3.8.1_3.

Affected software

ProductAffectedFixed in
Homebrewsafetypkg:brew/safetyOther threatsAffected
  • >=3.7.0_7 <3.8.1_3
Fixed in
  • 3.8.1_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in NLTK version 3.8.1_3. Users should upgrade to this version or later. The remediation involves routing all model-path file access through nltk.pathsec.open() or other pathsec-aware helpers and adding regression tests to ensure pathsec enforcement is effective. Until patched, avoid using untrusted input for model import/export paths with pathsec enabled.

Description

NLTK contains a file sandbox bypass vulnerability in several model-artifact APIs that use raw file operations on caller-controlled paths, bypassing path security enforcement. This allows reading or writing files outside of allowed root directories despite pathsec restrictions. The flaw affects versions from 3.7.0_7 up to but not including 3.8.1_3. A patch is available in version 3.8.1_3.

References

Community reviews

Loading reviews…