Skip to main content
CVE-2026-63402VulnerabilityPublished Updated

Node i18next: Prior to version 26.3.4, deepExtend in src/utils.js checks property existence with the in operator and

Affects node-i18nextSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-63402· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 26.3.4 : update node-i18next when convenient.

Data as of 5 Nov 2026, 12:34 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.15.9
Patch
Available – fixed in 26.3.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-i18nextpkg:deb/ubuntu/node-i18next?arch=source&distro=stonkingOther threatsAffected
  • =23.7.6-1build2
Fixed in–
Ubuntu 26.04 LTSnode-i18nextpkg:deb/ubuntu/node-i18next?arch=source&distro=resoluteOther threatsAffected
  • =23.7.6-1build2
Fixed in–
Ubuntu 24.04 LTSnode-i18nextpkg:deb/ubuntu/node-i18next?arch=source&distro=nobleOther threatsAffected
  • =22.4.8-1
  • =23.7.6-1
  • =23.7.6-1build2
Fixed in–
Ubuntu 22.04 LTSnode-i18nextpkg:deb/ubuntu/node-i18next?arch=source&distro=jammyOther threatsAffected
  • 19.8.4+dfsg-1 – 21.6.11+dfsg-1
5 affected builds
Fixed in–
Ubuntu 20.04 LTSnode-i18nextpkg:deb/ubuntu/node-i18next?arch=source&distro=focalOther threatsAffected
  • =17.0.18-1
  • =19.0.1+dfsg-1
  • =19.0.2+dfsg-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

i18next is an internationalization framework for JavaScript. Prior to version 26.3.4, `deepExtend` in `src/utils.js` checks property existence with the in operator and recurses into inherited built-ins reached through `Object.prototype`. An application must explicitly pass attacker-controlled resource data to `addResourceBundle(lng, ns, data, deep, overwrite)` with both `deep: true` and `overwrite: true`. Source keys such as `hasOwnProperty`, `toString` and `valueOf` can then select shared inherited built-in function objects, and a nested value can overwrite a property of those objects process-wide. For example, making `Object.prototype.hasOwnProperty.call` non-callable causes subsequent uses, including i18next internals, to throw TypeError, resulting in unrecoverable denial of service and limited integrity impact. The `__proto__`/`constructor` guard does not prevent this mechanism because the corruption target is an inherited built-in function rather than the prototype object itself. Default calls without deep merging or with overwrite falsy are unaffected, and no standard i18next backend or integration uses the vulnerable configuration. This issue is distinct from the setPath/key-walking prototype-pollution flaws in i18next-fs-backend (CVE-2026-48713) and i18next-http-middleware (CVE-2026-48714). This issue is fixed in version 26.3.4.

References

Community reviews

Loading reviews…