CVE-2026-59870: Node js yaml · js-yaml is a JavaScript YAML parser and dumper
Affects node-js-yamlSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 5.2.1 : patch node-js-yaml soon.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Affects
- js-yaml prior to 5.2.1
- Patch
- Available – fixed in 5.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10node-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10node-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in js-yaml version 5.2.1. Users should upgrade to version 5.2.1 or later to remediate this issue.
Description
CVE-2026-59870 is a medium-severity vulnerability in the js-yaml library used by nodeca. It results in excessive CPU consumption due to inefficient quadratic time complexity when processing the !!omap tag in YAML documents. This can cause denial of service by exhausting CPU resources. The vulnerability affects multiple versions of js-yaml prior to 5.2.1. A fix is available in version 5.2.1.
References
- ubuntu.com/security/CVE-2026-59870 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-59870 (opens in a new tab)
- github.com/nodeca/js-yaml/security/advisories/GHSA-724g-mxrg-4qvm (opens in a new tab)
- github.com/nodeca/js-yaml/commit/22a8071ef032117bc6249c330b240ac3aa2d3ded (opens in a new tab)
- github.com/nodeca/js-yaml/commit/39f3211a2f01b3c6982710cf21434ab7060acefe (opens in a new tab)
- github.com/nodeca/js-yaml/commit/c3cc4b0bb9ddb9af2dd9b61e0d56f5ce7983cd4a (opens in a new tab)
- github.com/nodeca/js-yaml/releases/tag/3.15.1 (opens in a new tab)
- github.com/nodeca/js-yaml/releases/tag/4.3.1 (opens in a new tab)
- github.com/nodeca/js-yaml/releases/tag/5.2.1 (opens in a new tab)