Skip to main content
CVE-2026-92596VulnerabilityPublished Updated

Node nodemailer: Nodemailer before 9.1.0 contains a quadratic time complexity vulnerability in the addressparser

Affects node-nodemailerSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High · fixed in 9.1.0 : patch node-nodemailer soon.

Data as of 29 Oct 2026, 00:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=stonkingOther threatsAffected
  • 8.0.4+~7.0.11-1 – 9.0.5+~8.0.1-1
5 affected builds
Fixed in–
Ubuntu 26.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=resoluteOther threatsAffected
  • 7.0.5+~7.0.1-1 – 8.0.4+~7.0.11-1
5 affected builds
Fixed in–
Ubuntu 24.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=nobleOther threatsAffected
  • =6.9.4+~6.4.9-2
  • =6.9.4+~6.4.9-3ubuntu1
  • =6.9.4+~6.4.9-4
Fixed in–
Ubuntu 22.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=jammyOther threatsAffected
  • 6.4.17-3 – 6.7.1+~6.4.4-1
4 affected builds
Fixed in–
Ubuntu 20.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=focalOther threatsAffected
  • 6.3.0-2 – 6.4.5-1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Nodemailer version 9.1.0 and later. Users should upgrade to version 9.1.0 or newer to remediate this vulnerability. No vendor advisory content was provided, but the version information indicates that versions before 9.1.0 are affected and the issue is resolved in 9.1.0.

Description

Nodemailer versions before 9.1.0 have a vulnerability in the addressparser component that causes quadratic time complexity when processing comma-separated address lists. This flaw allows remote attackers to send a crafted email with many addresses, leading to denial of service by consuming 100% CPU and freezing the Node.js event loop.

References

Community reviews

Loading reviews…