Skip to main content
CVE-2026-110871VulnerabilityPublished Updated

Node nodemailer: Nodemailer from 3.0.0 before 10.0.10 contains a denial of service vulnerability in

Affects node-nodemailerSource GCVE Database

0
Authoritative record:CVE-2026-110871· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in 10.0.10 : patch node-nodemailer soon.

Data as of 28 Oct 2026, 23:57 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.0.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 32 minutes before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 6 days after disclosure

  4. In Threat Radar

    record ingested

    , 12 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=stonkingOther threatsAffected
  • 8.0.4+~7.0.11-1 – 9.0.5+~8.0.1-1
5 affected builds
Fixed in–
Ubuntu 26.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=resoluteOther threatsAffected
  • 7.0.5+~7.0.1-1 – 8.0.4+~7.0.11-1
5 affected builds
Fixed in–
Ubuntu 24.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=nobleOther threatsAffected
  • =6.9.4+~6.4.9-2
  • =6.9.4+~6.4.9-3ubuntu1
  • =6.9.4+~6.4.9-4
Fixed in–
Ubuntu 22.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=jammyOther threatsAffected
  • 6.4.17-3 – 6.7.1+~6.4.4-1
4 affected builds
Fixed in–
Ubuntu 20.04 LTSnode-nodemailerpkg:deb/ubuntu/node-nodemailer?arch=source&distro=focalOther threatsAffected
  • 6.3.0-2 – 6.4.5-1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Nodemailer version 10.0.10 and later. Users should upgrade to version 10.0.10 or newer to remediate this vulnerability. No other mitigation or temporary workaround is indicated.

Description

Nodemailer versions from 3.0.0 up to but not including 10.0.10 contain a denial of service vulnerability in the MessageParser.parseHeaders function. This flaw allows attackers to exhaust CPU resources by supplying large recipient lists or long headers that unfold into tens of thousands of continuation lines, blocking the Node.js event loop during DKIM signing.

References

Community reviews

Loading reviews…