Node2Shell: Brotli Flaw Triggers Patching Across Microsoft, Node.js, Python Packages
Source SecurityWeek
Not known to be exploited · CVSS 9.2 Critical · fixed in 1.2.1 : patch Brotli as a priority.
Data as of 26 Oct 2026, 11:02 UTC
- Patch
- Available – fixed in 1.2.1, 1.1.1, 1.0.10
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.
What to do
Upgrade Brotli and github.com/google/brotli to 1.2.1, 1.1.1 or 1.0.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Brotligithub.com/google/brotli | Affected
| Fixed in
|
| Brotligithub.com/google/brotli | Affected
| Fixed in
|
| Brotligithub.com/google/brotli | Affected
| Fixed in
|
GitHubgithub.com/google/brotlipkg:github/github.com/google/brotliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixes are available in Brotli versions 1.0.10, 1.1.1, and 1.2.1, and corresponding patches have been released by Microsoft for .NET, Visual Studio, and PowerShell, as well as by Node.js and Python package maintainers. Users should apply these updates promptly. Additionally, affected services and container images must be restarted or rebuilt to ensure the patched Brotli decoder is loaded, as running processes continue to use vulnerable code until restarted.
Description
CVE-2026-111497, dubbed Node2Shell, is a critical out-of-bounds write vulnerability in Google’s Brotli decoder affecting versions 1.0.3 through 1.2.0. It impacts multiple platforms including Node.js, .NET, PowerShell, and Python packages, allowing unauthenticated attackers to cause memory corruption that can lead to process crashes, memory leaks, or arbitrary code execution. The flaw has been patched in Brotli versions 1.0.10, 1.1.1, and 1.2.1, with corresponding updates released by Microsoft, Node.js, and Python package maintainers. No exploitation in the wild has been reported, but proof-of-concept code demonstrates code execution on certain Linux arm64 Node.js builds. The vulnerability arises when attacker-controlled compressed data is processed by the affected Brotli decoder.