Skip to main content
CVE-2026-121426VulnerabilityPublished

Nodemailer from 3.0.0 before 10.1.4 contains an address parsing vulnerability in addressparser that ends an angle-addr

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121426· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade to 10.1.4 soon.

Data as of 3 Nov 2026, 16:28 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.3
CNA (VulnCheck)CVSS 3.16.5
Patch
Available – fixed in 10.1.4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade nodemailer to 10.1.4.

Affected software

ProductAffectedFixed in
nodemailernodemailerAffected
  • >=3.0.0 <10.1.4
Fixed in
  • 10.1.4
npmnodemailerpkg:npm/nodemailerOther threatsAffected
  • >=3.0.0 <10.1.4
Fixed in
  • 10.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of Nodemailer is available starting from 10.1.4. Users should upgrade to version 10.1.4 or later to remediate this vulnerability. Since the vulnerability affects versions before 10.1.4, upgrading to this or a later version fully addresses the issue.

Description

Nodemailer versions from 3.0.0 up to but not including 10.1.4 contain an address parsing vulnerability in the addressparser component. This flaw causes the parser to incorrectly end an angle-addr at a '>' character inside a quoted local part, comment, or domain literal. As a result, attackers can craft email addresses that appear to belong to allowed domains but are actually delivered to attacker-controlled domains, bypassing recipient allow lists and potentially exposing message content.

References

Community reviews

Loading reviews…