Parse Server before 8.6.111 and 9.0.0 before 9.10.6-alpha.3 on MongoDB skips field type validation for null-valued dot
Source GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.10.6-alpha.3 when convenient.
Data as of 3 Nov 2026, 16:30 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- Patch
- Available – fixed in 9.10.6-alpha.3, 8.6.111
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade parse-server to 9.10.6-alpha.3; parse-server to 8.6.111; parse-server to 9.10.6-alpha.3 or 8.6.111.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict write access to trusted clients only and disable public writes if enabled to reduce exposure.
Description
Parse Server versions before 8.6.111 and 9.0.0 before 9.10.6-alpha.3 using MongoDB do not properly validate field types for null-valued dot notation keys. This allows sub-documents to be written under fields expected to hold Pointer, Number, String, Date, or Boolean values. Clients with write access, including unauthenticated clients if public writes are enabled, can exploit this to corrupt data fields, cause objects to become unreadable, or disrupt atomic operations on number fields.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-655c-2xf3-77x9 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-121415 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10804 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10805 (opens in a new tab)
- vulncheck.com/advisories/parse-server-before-8.6.111-and-9.0.0-before-9.10.6-alpha.3-field-corruption-via-null-dot-notation-key (opens in a new tab)