Skip to main content
VulnerabilityPublished Updated

CVE-2025-6491: PHP SOAP Extension · NULL Pointer Dereference

Affects phpSource GCVE Database

0
Authoritative record:CVE-2025-6491· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 8.4.10 : update php when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.10, 8.3.23, 8.2.29 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade php to 8.4.10, 8.3.23, 8.2.29 or 8.1.33.

Affected software

ProductAffectedFixed in
Bitnamiphppkg:bitnami/phpOther threatsAffected
  • <8.1.33
  • >=8.2.0 <8.2.29
  • >=8.3.0 <8.3.23
  • >=8.4.0 <8.4.10
Fixed in
  • 8.1.33
  • 8.2.29
  • 8.3.23
  • 8.4.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to PHP versions 8.1.33 or later, 8.2.29 or later, 8.3.23 or later, or 8.4.10 or later to remediate this issue.

Description

A vulnerability in the PHP SOAP extension allows a null pointer dereference when parsing XML data with an overly large XML namespace prefix exceeding 2GB. This issue affects PHP versions prior to 8.1.33, 8.2.29, 8.3.23, and 8.4.10. The flaw may cause server crashes, impacting availability.

References

Community reviews

Loading reviews…