NXP MCUXpresso SDK USB middleware (mcuxsdk-middleware-usb) before 2.13.0 contains a heap buffer overflow in host
Source GCVE Database
Not known to be exploited · CVSS 7.0 High : upgrade to 2.13.0 soon.
Data as of 26 Oct 2026, 16:50 UTC
- Patch
- Available – fixed in 2.13.0
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade mcuxsdk-middleware-usb and nxp-mcuxpresso/mcuxsdk-middleware-usb to 2.13.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NXPmcuxsdk-middleware-usb | Affected
| Fixed in
|
GitHubnxp-mcuxpresso/mcuxsdk-middleware-usbpkg:github/nxp-mcuxpresso/mcuxsdk-middleware-usbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in NXP MCUXpresso SDK USB middleware version 2.13.0 and later. Users should upgrade to version 2.13.0 or newer to remediate this vulnerability. No additional mitigation guidance is provided in the advisory.
Description
NXP MCUXpresso SDK USB middleware versions before 2.13.0 contain a heap buffer overflow vulnerability in the host audio, video, and CDC class drivers. This flaw arises because the drivers trust device-supplied bNumEndpoints and bLength values without proper validation. A malicious USB device can exploit this by supplying crafted descriptors that overflow the fixed-size epList array, leading to heap memory corruption. This can result in code execution or denial of service on the affected system.
References
- nvd.nist.gov/vuln/detail/CVE-2026-116488 (opens in a new tab)
- github.com/nxp-mcuxpresso/mcuxsdk-middleware-usb/commit/264b8e6849e609abd8e2b045bc7786818b0d2bbc (opens in a new tab)
- github.com/nxp-mcuxpresso/mcuxsdk-middleware-usb/commit/6a1d1a7c32026e6d83504415931c4ae97ef7b7a1 (opens in a new tab)
- github.com/nxp-mcuxpresso/mcuxsdk-middleware-usb/commit/f615b03e302f0c58de5bf1cfeb31dfb85a2e514a (opens in a new tab)
- github.com/nxp-mcuxpresso/mcuxsdk-middleware-usb (opens in a new tab)
- github.com/nxp-mcuxpresso/mcuxsdk-middleware-usb/blob/release/26.06.00/host/class/usb_host_audio.c (opens in a new tab)
- mcuxpresso.nxp.com/mcuxsdk/latest/release/index.html (opens in a new tab)
- vulncheck.com/advisories/nxp-mcuxpresso-sdk-usb-middleware-before-2.13.0-heap-overflow-via-host-class-drivers (opens in a new tab)