Skip to main content
CVE-2026-119028VulnerabilityPublished

oapi-codegen 2.0.0 before 2.8.1 contains a code injection vulnerability that allows attackers to inject Go code by

Affects oapi-codegenSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119028· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 2.8.1 soon.

Data as of 29 Oct 2026, 13:34 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 2.8.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade github.com/oapi-codegen/oapi-codegen to 2.8.1.

Affected software

ProductAffectedFixed in
Gogithub.com/oapi-codegen/oapi-codegenpkg:golang/github.com/oapi-codegen/oapi-codegenOther threatsAffected
  • >=2.0.0 <2.8.1
Fixed in
  • 2.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in oapi-codegen version 2.8.1 and later. Users should upgrade to version 2.8.1 or newer to remediate this vulnerability. There is no indication that any temporary or alternative mitigations exist. No cloud service is involved, so remediation depends on applying the patch.

Description

oapi-codegen versions from 2.0.0 up to but not including 2.8.1 contain a code injection vulnerability. This flaw allows attackers who control an OpenAPI document to inject arbitrary Go code by supplying non-literal enum entries in integer, number, or boolean schemas. The injected code executes during the build and import of the generated package, potentially leading to full compromise.

References

Community reviews

Loading reviews…