oapi-codegen 2.5.0 before 2.8.1 contains a code injection vulnerability that allows attackers to inject Go code by
Affects oapi-codegenSource GCVE Database
Not known to be exploited · CVSS 7.7 High.
Data as of 29 Oct 2026, 13:34 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Gogithub.com/oapi-codegen/oapi-codegenpkg:golang/github.com/oapi-codegen/oapi-codegenOther threats | Affected– | Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade oapi-codegen to version 2.8.1 or later, where this vulnerability is fixed. No other mitigation or temporary fix is indicated. Patch status is confirmed by the version range affected and fixed version stated.
Description
oapi-codegen versions from 2.5.0 up to but not including 2.8.1 contain a code injection vulnerability. This flaw allows attackers who control an OpenAPI document to inject arbitrary Go code via a crafted servers[].x-go-name value. The injected code executes when the victim builds and imports the generated package, potentially leading to full compromise of confidentiality, integrity, and availability.
References
- github.com/oapi-codegen/oapi-codegen/security/advisories/GHSA-g2vv-83pm-v2hc (opens in a new tab)
- github.com/oapi-codegen/oapi-codegen/security/advisories/GHSA-rjwr-m7qx-3fjr (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119027 (opens in a new tab)
- github.com/oapi-codegen/oapi-codegen/pull/2626 (opens in a new tab)
- github.com/oapi-codegen/oapi-codegen/commit/068f1bcd16e4724c72d78d6774008a877b8297b1 (opens in a new tab)
- github.com/oapi-codegen/oapi-codegen/blob/v2.5.0/pkg/codegen/templates/server-urls.tmpl (opens in a new tab)
- github.com/oapi-codegen/oapi-codegen/blob/v2.8.0/pkg/codegen/templates/server-urls.tmpl (opens in a new tab)
- github.com/oapi-codegen/oapi-codegen/releases/tag/v2.8.1 (opens in a new tab)
- vulncheck.com/advisories/oapi-codegen-2.5.0-before-2.8.1-code-injection-via-servers-x-go-name-extension (opens in a new tab)