Skip to main content
CVE-2026-118669VulnerabilityPublished

gcalcli · OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client

Affects gcalcliSource GCVE Database

0
Compare
Authoritative record:CVE-2026-118669· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 4.5.1_14 soon.

Data as of 31 Oct 2026, 16:21 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.4
Patch
Available – fixed in 4.5.1_14
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gcalcli to 4.5.1_14.

Affected software

ProductAffectedFixed in
Homebrewgcalclipkg:brew/gcalcliOther threatsAffected
  • >=4.4.0 <4.5.1_14
Fixed in
  • 4.5.1_14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OAuthlib version 4.5.1_14 that addresses this issue. Users should upgrade to this fixed version to remediate the vulnerability. Until patched, deployments should verify that their RequestValidator implementations do not authorize based solely on the client_id argument and instead rely on the authenticated client object to prevent misuse. No other specific mitigations are indicated.

Description

OAuthlib contains a vulnerability in its token grant handlers where an authenticated low-privilege client can supply a different client_id in the token request body, causing authorization checks to be performed under that other client's identity. This affects the client_credentials and password grant flows. The flaw arises because OAuthlib does not require the authenticated client's client_id to match the client_id used for grant and scope validation, allowing token issuance with unauthorized scopes or grant types. The issue requires the attacker to have valid credentials for a lower-privilege client and depends on the application's validator using the client_id argument for authorization. A fix is available in version 4.5.1_14.

References

Community reviews

Loading reviews…