Skip to main content
CVE-2026-118669VulnerabilityPublished

mcp-atlassian · OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client

Affects mcp-atlassianSource GCVE Database

0
Compare
Authoritative record:CVE-2026-118669· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 0.23.1_1 soon.

Data as of 31 Oct 2026, 16:52 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.4
Patch
Available – fixed in 0.23.1_1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade mcp-atlassian to 0.23.1_1.

Affected software

ProductAffectedFixed in
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threatsAffected
  • >=0.11.9 <0.23.1_1
Fixed in
  • 0.23.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OAuthlib version 0.23.1_1 that addresses this issue. Users should upgrade to version 0.23.1_1 or later to remediate this vulnerability. Until patched, applications should ensure their RequestValidator implementations do not rely solely on the client_id argument passed by OAuthlib for authorization decisions and instead strictly verify that the authenticated client matches the client_id used in grant and scope validation.

Description

OAuthlib contains a vulnerability in its token grant handlers where an authenticated low-privilege client can supply a different client_id in the token request body, causing grant and scope validation to be performed under that other client identity. This affects the client_credentials and password grant flows. The issue arises because OAuthlib does not require the authenticated client's client_id to match the client_id parameter in the request body, allowing authorization checks to be bypassed. This can lead to unauthorized issuance of tokens with elevated scopes or grant types. A fix is available in version 0.23.1_1.

References

Community reviews

Loading reviews…