CVE-2026-86000: Soup Sieve · Polynomial-time ReDoS (O(n²)) in the `IDENTIFIER` / `VALUE` selector sub-patterns
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.23.1 when convenient.
Data as of 30 Oct 2026, 08:15 UTC
- Patch
- Available – fixed in 0.23.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.23.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in soupsieve version 0.23.1 that fixes the regex backtracking issue. Users and applications relying on soupsieve or BeautifulSoup with user-supplied selectors should upgrade to version 0.23.1 or later. If upgrading is not immediately possible, avoid passing user-controlled input directly to soupsieve or BeautifulSoup select methods to prevent exploitation.
Description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in soupsieve's CSS selector parsing due to a quadratic-time regex backtracking issue in the IDENTIFIER and VALUE sub-patterns. This flaw can cause the interpreter to stall for seconds or minutes when processing crafted selectors with long identifier or attribute value runs that fail to match. The vulnerability is exploitable when user-controlled selectors are passed to soupsieve or BeautifulSoup's select methods. It affects soupsieve versions from 0.11.9 up to but not including 0.23.1. A fix is available in version 0.23.1.
References
- github.com/facelessuser/soupsieve/security/advisories/GHSA-gjv8-xp57-g29c (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-86000 (opens in a new tab)
- github.com/facelessuser/soupsieve/commit/ce44e4996e6632871c18cdd7a7fb641be8ef34ef (opens in a new tab)
- github.com/facelessuser/soupsieve (opens in a new tab)
- github.com/facelessuser/soupsieve/releases/tag/2.9 (opens in a new tab)