CVE-2026-54283: Starlette · request.form() limits silently ignored for application/x-www-form-urlencoded enable DoS
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.21.1_8 soon.
Data as of 30 Oct 2026, 08:16 UTC
- Patch
- Available – fixed in 0.21.1_8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.21.1_8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Starlette version 0.21.1_8 or later, which properly forwards and enforces max_fields and max_part_size limits for application/x-www-form-urlencoded parsers. The patched version raises errors before accumulating excessive fields or large field values. The default limits are max_fields=1000 and max_part_size=1MB, configurable via request.form().
Description
Starlette's request.form() method does not enforce configured limits on the number and size of fields for application/x-www-form-urlencoded content types, unlike multipart/form-data. This allows unauthenticated attackers to send requests with an arbitrarily large number of fields or very large fields, causing denial of service by blocking the event loop or exhausting memory. The vulnerability affects versions from 0.11.9 up to but not including 0.21.1_8. A patched version 0.21.1_8 is available that enforces these limits properly.