caret, tilde, betterem · pymdown-extensions: exponential-backtracking ReDoS
Affects mcp-atlassianSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 0.22.0 soon.
Data as of 30 Oct 2026, 08:15 UTC
- Patch
- Available – fixed in 0.22.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.22.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in pymdown-extensions version 0.22.0 that fixes the vulnerable regular expressions. Users should upgrade to version 0.22.0 or later to remediate this issue. Until upgraded, avoid rendering untrusted Markdown input with the affected extensions enabled in their default configuration.
Description
pymdown-extensions versions from 0.11.9 up to but not including 0.22.0 contain a Regular Expression Denial of Service (ReDoS) vulnerability in four inline processors: caret, tilde, betterem, and magiclink. These processors use regular expressions with exponential backtracking, which can cause markdown rendering to consume unbounded CPU time when processing crafted untrusted Markdown input under 50 bytes. The issue affects the default configuration and is exploitable via the documented public API. A fix is available in version 0.22.0.
References
- github.com/facelessuser/pymdown-extensions/security/advisories/GHSA-gm37-52c6-37mw (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-67422 (opens in a new tab)
- github.com/facelessuser/pymdown-extensions/commit/c68498598d7b13011bb4571350b6e3612a4ce44b (opens in a new tab)
- github.com/facelessuser/pymdown-extensions (opens in a new tab)