Skip to main content
VulnerabilityPublished Updated

CVE-2026-25125: October Rain has Environment Variable Exfiltration via INI Parser Interpolation

Affects october/rainSource GCVE Database

0
Authoritative record:CVE-2026-25125· Medium 4.9

Not known to be exploited · CVSS 4.9 Medium : upgrade to 4.1.10 when convenient.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
4.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.1.10, 3.7.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade october/rain to 4.1.10; october/rain to 3.7.14.

Affected software

ProductAffectedFixed in
Packagistoctober/rainAffected
  • >=4.0.0 <4.1.10
Fixed in
  • 4.1.10
Packagistoctober/rainAffected
  • <3.7.14
Fixed in
  • 3.7.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A server-side information disclosure vulnerability was identified in the INI settings parser. PHP's `parse_ini_string()` function supports `${}` syntax for environment variable interpolation. Attackers with Editor access could inject `${APP_KEY}`, `${DB_PASSWORD}`, or similar patterns into CMS page settings fields, causing sensitive environment variables to be resolved and stored in the template. These values were then returned to the attacker when the page was reopened. ### Impact - Exfiltration of sensitive environment variables (APP_KEY, DB credentials, AWS keys, etc.) - Could enable further attacks: database access, cookie forgery, AWS resource access - Requires authenticated backend access with Editor permissions - Only relevant when `cms.safe_mode` is enabled (otherwise direct PHP injection is already possible) ### Patches The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version. ### Workarounds If upgrading immediately is not possible: - Restrict Editor tool access to fully trusted administrators only - Ensure database and cloud service credentials are not accessible from the web server's network ### References - Reported by Pentest-Tools.com

References

Community reviews

Loading reviews…