Skip to main content
CVE-2026-109518VulnerabilityPublished

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-109518· High 7.7

Not known to be exploited · CVSS 7.7 High · fixed in 3.3.6 : patch APT soon.

Data as of 4 Nov 2026, 19:58 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (canonical)CVSS 4.07.7
Patch
Available – fixed in 3.3.6, 3.2.1, 3.0.4 +17
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
APTaptAffected
  • <1.2.36
  • >=1.4.0 <1.4.12
  • >=1.6.0 <1.6.19
  • >=1.8.0 <1.8.2.4
  • >=1.8.3 <=1.8.5
  • >=2.0.0 <2.0.12
  • >=2.2.0 <2.2.5
  • >=2.4.0 <2.4.15
  • >=2.6.0 <2.6.2
  • >=2.8.0 <2.8.4
  • >=3.0.0 <3.0.4
  • >=3.2.0 <3.2.1
  • >=3.3.0 <3.3.6
Fixed in
  • 3.3.6
  • 3.2.1
  • 3.0.4
  • 2.8.4
  • 2.6.2
  • 2.4.15
  • 2.2.5
  • 2.0.12
  • 1.8.2.4
  • 1.6.19
  • 1.4.12
  • 1.2.36
APTaptAffected
  • >=3.3.0 <3.3.3ubuntu0.1
Fixed in
  • 3.3.3ubuntu0.1
APTaptAffected
  • >=3.2.0 <3.2.1ubuntu0.1
Fixed in
  • 3.2.1ubuntu0.1
APTaptAffected
  • >=2.8.0 <2.8.4ubuntu0.1
Fixed in
  • 2.8.4ubuntu0.1
APTaptAffected
  • >=2.4.0 <2.4.15ubuntu0.1
Fixed in
  • 2.4.15ubuntu0.1
APTaptAffected
  • >=2.0.0 <2.0.12+esm1
Fixed in
  • 2.0.12+esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixes have been released by Debian and Ubuntu. Users should apply the official security updates provided in the advisories at https://lists.debian.org/debian-security-announce/2026/msg00526.html and https://ubuntu.com/security/notices/USN-8996-1. Systems running Debian 12 or Ubuntu 22.04 LTS and later should ensure these patches are applied. Older releases with the default Acquire::Retries set to zero are not affected by default. No additional mitigation is required beyond applying the official patches.

Description

A vulnerability in Debian, Ubuntu, and derivative Linux distributions allows an on-path attacker who can manipulate HTTP traffic between an APT client and archive server to trick the client into installing an attacker-controlled unverified package. This can lead to remote code execution with root privileges. The issue arises from the reuse of hard links and requires the client to follow redirects and retry downloads, which depends on a non-zero Acquire::Retries setting. The default setting enabling this behavior is present starting with Debian 12 and Ubuntu 22.04 LTS, making older releases unaffected by default.

References

Community reviews

Loading reviews…