Skip to main content
VulnerabilityPublished Updated

Open WebUI has vulnerable dependency on starlette via fastapi

Affects open-webuiSource GCVE Database

0

CVSS 7.5 High : upgrade to 0.5.8 soon.

Data as of 26 Oct 2026, 16:28 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.5.8
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

What to do

Upgrade open-webui to 0.5.8.

Affected software

ProductAffectedFixed in
PyPIopen-webuiAffected
  • <0.5.8
Fixed in
  • 0.5.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions <=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.

References

Community reviews

Loading reviews…