Skip to main content
VulnerabilityPublished Updated

CVE-2024-6706: Open WebUI Stored Cross-Site Scripting Vulnerability

Affects open-webuiSource GCVE Database

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 0.3.14 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.3.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade open-webui to 0.3.14.

Affected software

ProductAffectedFixed in
PyPIopen-webuiAffected
  • <0.3.14
Fixed in
  • 0.3.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Attackers can craft a malicious prompt that coerces the language model into executing arbitrary JavaScript in the context of the web page.

References

Community reviews

Loading reviews…