Skip to main content
CVE-2026-123540VulnerabilityPublished

OpenAM before 16.1.4 contains an incomplete output encoding vulnerability that allows a SAML 1.x identity provider to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123540· Low 2.0

Not known to be exploited · CVSS 2.0 Low : upgrade to 16.1.4 when convenient.

Data as of 8 Nov 2026, 06:48 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.0
CNA (VulnCheck)CVSS 3.12.0
Patch
Available – fixed in 16.1.4
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade OpenAM to 16.1.4.

Affected software

ProductAffectedFixed in
OpenIdentityPlatformOpenAMAffected
  • <16.1.4
Fixed in
  • 16.1.4
MavenOpenAMpkg:maven/OpenAMOther threatsAffected
  • <16.1.4
Fixed in
  • 16.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenAM version 16.1.4 or later. Users should upgrade to version 16.1.4 or newer to remediate this vulnerability. No other mitigation guidance is provided in the data.

Description

OpenAM versions prior to 16.1.4 have an incomplete output encoding vulnerability related to SAML 1.x identity providers. This flaw allows a trusted identity provider to inject unencoded content into the service provider's auto-submitted form, potentially altering attribute values. The vulnerability undermines the integrity of attributes received by the target application. The CVSS score is low, reflecting limited impact on confidentiality and availability, with some integrity impact.

References

Community reviews

Loading reviews…