Skip to main content
VulnerabilityPublished Updated

CVE-2026-45051: OpenAM · Pre-auth RCE via Java Deserialization in WebAuthn Authenticator Storage

Affects org.openidentityplatform.openam:openam-auth-webauthnSource GCVE Database

0
Authoritative record:CVE-2026-45051· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 16.1.1 as a priority.

Data as of 28 Oct 2026, 17:11 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.openidentityplatform.openam:openam-auth-webauthn to 16.1.1.

Affected software

ProductAffectedFixed in
Mavenorg.openidentityplatform.openam:openam-auth-webauthnAffected
  • <16.1.1
Fixed in
  • 16.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade OpenAM Community Edition to version 16.1.1 or later, where this vulnerability is patched. Additionally, administrators should ensure that the storage attribute used by the WebAuthn module is not user-writable and is properly managed by the server. Avoid configurations that allow delegated administration or provisioning to write attacker-controlled data to this attribute. No other mitigations are indicated by the vendor advisory.

Description

A deserialization of untrusted data vulnerability (CWE-502) exists in OpenAM's WebAuthn authentication module, affecting versions prior to 16.1.1. Exploitation requires that an attacker can write attacker-controlled data to a storage attribute read by the WebAuthn module, which is not the default configuration but possible in some deployments. Successful exploitation allows arbitrary code execution as the application server user. The issue is patched in OpenAM Community Edition version 16.1.1.

References

Community reviews

Loading reviews…