CVE-2026-53806: OpenClaw · Combined POSIX shell options could confuse exec revalidation
Affects openclaw-cliSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2026.5.12 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.5.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openclaw and openclaw-cli to 2026.5.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmopenclaw | Affected
| Fixed in
|
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in version 2026.5.12 and should be applied. Until patched, avoid using combined shell option forms in allowlisted commands. Additionally, narrow channel and tool allowlists, avoid sharing a Gateway between mutually untrusted users, and disable the affected feature if it is not needed.
Description
OpenClaw CLI versions prior to 2026.5.12 contain a vulnerability where combined POSIX shell options can cause confusion during exec revalidation. This may lead to inline shell commands executing without proper allowlist approval. The issue affects configurations where the feature is enabled and reachable, potentially allowing unintended command execution depending on operator setup. The vulnerability does not alter the trusted-operator model of OpenClaw. A fix is available in version 2026.5.12.
References
- github.com/openclaw/openclaw/security/advisories/GHSA-vxx3-6hc9-7cc3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53806 (opens in a new tab)
- github.com/openclaw/openclaw (opens in a new tab)
- vulncheck.com/advisories/openclaw-shell-option-parsing-bypass-in-exec-revalidation (opens in a new tab)