CVE-2026-53813: OpenClaw · Fake package roots could influence memory-core artifact loading
Affects openclaw-cliSource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 2026.4.25 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.4.25
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade openclaw and openclaw-cli to 2026.4.25.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmopenclaw | Affected
| Fixed in
|
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in openclaw-cli version 2026.4.25. Operators should upgrade to this version to remediate the vulnerability. Until patched, run memory-core flows only from trusted workspaces. Additionally, keep channel and tool allowlists narrow, avoid sharing a Gateway between mutually untrusted users, and disable the affected feature when it is not needed.
Description
OpenClaw CLI versions prior to 2026.4.25 contain a vulnerability where fake package roots can influence memory-core artifact loading. This occurs because a local package root resolution path, influenced by workspace state, may select an unintended package root. The vulnerability affects configurations where the feature is enabled and reachable, potentially allowing loading of memory-core artifacts from unintended local locations. The impact depends on operator configuration and whether lower-trust input can reach the affected path. The vulnerability is patched starting from version 2026.4.25. Until patched, it is recommended to run memory-core flows only from trusted workspaces and apply general hardening such as narrowing allowlists and disabling the feature when not needed.
References
- github.com/openclaw/openclaw/security/advisories/GHSA-v8cx-933x-r976 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53813 (opens in a new tab)
- github.com/openclaw/openclaw (opens in a new tab)
- vulncheck.com/advisories/openclaw-arbitrary-artifact-loading-via-fake-package-root-resolution (opens in a new tab)