Skip to main content
CVE-2026-41373VulnerabilityPublished Updated

OpenClaw: Incomplete host-env-security-policy allows untrusted model to substitute compiler binaries via env overrides

Affects openclawSource GCVE Database

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2026.3.31 when convenient.

Data as of 27 Oct 2026, 01:55 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.3.31
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openclaw to 2026.3.31.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.3.31
Fixed in
  • 2026.3.31

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenClaw to version 2026.3.31 or later, which includes a fix that properly restricts environment variable overrides for compiler binaries in the host environment security policy. Since a patch is available and the vulnerability requires an approved host-exec request, applying the official fix is the recommended mitigation.

Description

OpenClaw versions up to 2026.3.28 have an incomplete host environment security policy that allows an untrusted model to override compiler binary environment variables (such as CC, CXX, CARGO_BUILD_RUSTC, CMAKE_C_COMPILER) during approved host execution requests. This vulnerability is mitigated in version 2026.3.31 and later. Exploitation requires an approved host-exec request within the existing execution trust domain, limiting the severity to medium.

References

Community reviews

Loading reviews…